import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<DATA>*<\\DATA>";
final String string = "<DATA><Status>E</Status><StatusCode>501</StatusCode><Description>Duplicate Integrator Trasaction ID</Description><CasinoID>0</CasinoID><OperatorID>0</OperatorID><UserName>0</UserName><UserPWD>0</UserPWD><UserID>0</UserID><UserType></UserType><Amount>0</Amount><Currency>XXX</Currency><TransactionType></TransactionType><TransactionID>0000000001</TransactionID></DATA>INSERT INTO STG.dbo.CR_INTEGRATOR_REQUESTS (IntegratorTrnID, OperatorID) OUTPUT(INSERTED.ID) VALUES (0000000001, 75281)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}