package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^R\|1\|\^\^\^pH\^\^\^M\^1\||(?<1>\d+$)`)
var str = `H|\^&|||8^Roche^OMNI S^V8.00^1^5277^10.23.130.3||||||M|P|1394-97|20171124221834`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}