re = /^R\|1\|\^\^\^pH\^\^\^M\^1\||(?<1>\d+$)/
str = 'H|\\^&|||8^Roche^OMNI S^V8.00^1^5277^10.23.130.3||||||M|P|1394-97|20171124221834'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end