import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^R\\|1\\|\\^\\^\\^pH\\^\\^\\^M\\^1\\||(?<1>\\d+$)";
final String string = "H|\\^&|||8^Roche^OMNI S^V8.00^1^5277^10.23.130.3||||||M|P|1394-97|20171124221834";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}