use strict;
my $str = 'H|\\^&|||8^Roche^OMNI S^V8.00^1^5277^10.23.130.3||||||M|P|1394-97|20171124221834';
my $regex = qr/^R\|1\|\^\^\^pH\^\^\^M\^1\||(?<1>\d+$)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}