package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(\d{2}\)\s(\d{4}-\d{5}|\d{5}-\d{4}|\d{4}-\d{4})`)
var str = `(99) 9999-99999 or (99) 99999-9999 or (99) 9999-9999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}