const regex = /\(\d{2}\)\s(\d{4}-\d{5}|\d{5}-\d{4}|\d{4}-\d{4})/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\(\\d{2}\\)\\s(\\d{4}-\\d{5}|\\d{5}-\\d{4}|\\d{4}-\\d{4})', 'g')
const str = `(99) 9999-99999 or (99) 99999-9999 or (99) 9999-9999`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}