import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\(\\d{2}\\)\\s(\\d{4}-\\d{5}|\\d{5}-\\d{4}|\\d{4}-\\d{4})";
final String string = "(99) 9999-99999 or (99) 99999-9999 or (99) 9999-9999";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}