re = /\(\d{2}\)\s(\d{4}-\d{5}|\d{5}-\d{4}|\d{4}-\d{4})/
str = '(99) 9999-99999 or (99) 99999-9999 or (99) 9999-9999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end