# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/"(.*?)\(\1\)":(.*\\/[a-zA-Z0-9]+)(?=\?|\,|\.|$)/<a href="$2">$1<\/a>/;t' <<< "\"text1(text1)\":http://www.example.com/mypage, ? ."