import Foundation
let pattern = #""(.*?)\(\1\)":(.*\/[a-zA-Z0-9]+)(?=\?|\,|\.|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""text1(text1)":http://www.example.com/mypage, ? ."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<a href="$2">$1</a>"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}