use strict;
my $str = '"text1(text1)":http://www.example.com/mypage, ? .';
my $regex = qr/"(.*?)\(\1\)":(.*\/[a-zA-Z0-9]+)(?=\?|\,|\.|$)/p;
my $subst = '<a href="$2">$1</a>';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";