import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"(.*?)\\(\\1\\)\":(.*\\/[a-zA-Z0-9]+)(?=\\?|\\,|\\.|$)";
final String string = "\"text1(text1)\":http://www.example.com/mypage, ? .";
final String subst = "<a href=\"$2\">$1</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}