using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\(.*?index: ([^)]+)";
string input = @"
(tag, index: develop-AB123-2s), (index: develop-CD123-2s)";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}