$re = '/\(.*?index: ([^)]+)/';
$str = '
(tag, index: develop-AB123-2s), (index: develop-CD123-2s)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);