package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\(.*?index: ([^)]+)`)
var str = `
(tag, index: develop-AB123-2s), (index: develop-CD123-2s)`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}