re = /\(.*?index: ([^)]+)/
str = '
(tag, index: develop-AB123-2s), (index: develop-CD123-2s)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end