using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<\/a>)([^>]*?)(\[\/caption\])";
string input = @"<a href=""some/link"">link 1</a><p>some really long description</p><a href=""another/link"">link 2</a>CAPTION TEXT HERE[/caption]";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}