const regex = /(<\/a>)([^>]*?)(\[\/caption\])/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<\\\/a>)([^>]*?)(\\[\\\/caption\\])', '')
const str = `<a href="some/link">link 1</a><p>some really long description</p><a href="another/link">link 2</a>CAPTION TEXT HERE[/caption]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}