re = /(<\/a>)([^>]*?)(\[\/caption\])/
str = '<a href="some/link">link 1</a><p>some really long description</p><a href="another/link">link 2</a>CAPTION TEXT HERE[/caption]'
# Print the match result
str.match(re) do |match|
puts match.to_s
end