$re = '/[?:\-\'\\\\\|.()\[\]{}/]/m';
$str = '\'a/b\',\'a # b\',\'a+b\'';
$subst = " ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;