# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*\s-s?n\s*(.+?)(?:\s-.*|$)/$1/;t' <<< "msqlsum81pv 0 0 25 25 25 2 -sn D:\\workdir\\PV 81\\config\\sum81pv.pwf -C 5000"