$re = '/.*\s-s?n\s*(.+?)(?:\s-.*|$)/';
$str = 'msqlsum81pv 0 0 25 25 25 2 -sn D:\\\\workdir\\\\PV 81\\\\config\\\\sum81pv.pwf -C 5000';
$subst = "$1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;