package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\s-s?n\s*(.+?)(?:\s-.*|$)`)
var str = []byte(`msqlsum81pv 0 0 25 25 25 2 -sn D:\\workdir\\PV 81\\config\\sum81pv.pwf -C 5000`)
var substitution = []byte("$1")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}