package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[#.]?[^{}]*{[^{}]*[{}][^{}]*}(*SKIP)(*F)|[#.]?[^{}]*{([^{}]+)}`)
var str = `{amdnia91(+wowa}
{amdn{ia91(+wowa}
.something{property:value;prop2:value}#something2{someprop:val;prop:val}
.something{property:value{;prop2:value}#something2{someprop:val;prop:val}
.something{property:v}alue;prop2:value}#something2{someprop:val;prop:val}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}