import re
regex = re.compile(r"[#.]?[^{}]*{[^{}]*[{}][^{}]*}(*SKIP)(*F)|[#.]?[^{}]*{([^{}]+)}")
test_str = ("{amdnia91(+wowa}\n"
"{amdn{ia91(+wowa}\n"
".something{property:value;prop2:value}#something2{someprop:val;prop:val}\n"
".something{property:value{;prop2:value}#something2{someprop:val;prop:val}\n"
".something{property:v}alue;prop2:value}#something2{someprop:val;prop:val}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")