$re = '/[#.]?[^{}]*{[^{}]*[{}][^{}]*}(*SKIP)(*F)|[#.]?[^{}]*{([^{}]+)}/';
$str = '{amdnia91(+wowa}
{amdn{ia91(+wowa}
.something{property:value;prop2:value}#something2{someprop:val;prop:val}
.something{property:value{;prop2:value}#something2{someprop:val;prop:val}
.something{property:v}alue;prop2:value}#something2{someprop:val;prop:val}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);