using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"# https://regex101.com/r/fP1oQ6/2
(?(DEFINE)#
(?<W>\s*)
(?<V>\d+(?:\.\d+)?(?&W))
(?<S>[-+]?)
(?<O>(?&W)[-+*\/](?&W))
(?<E>(?&S)(?:(?&V)|\((?&W)(?&E)(?&W)\))(?:(?&O)(?&E))?)#
)#
((?&E))";
string input = @"(8 - 1 + 3) * 6 - ((3 + 7) * 2)";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}