re = /# https:\/\/regex101.com\/r\/fP1oQ6\/2
(?(DEFINE)#
(?<W>\s*)
(?<V>\d+(?:\.\d+)?(?&W))
(?<S>[-+]?)
(?<O>(?&W)[-+*\/](?&W))
(?<E>(?&S)(?:(?&V)|\((?&W)(?&E)(?&W)\))(?:(?&O)(?&E))?)#
)#
((?&E))/x
str = '(8 - 1 + 3) * 6 - ((3 + 7) * 2)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end