// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)# https://regex101.com/r/fP1oQ6/2
(?(DEFINE)#
(?<W>\s*)
(?<V>\d+(?:\.\d+)?(?&W))
(?<S>[-+]?)
(?<O>(?&W)[-+*\/](?&W))
(?<E>(?&S)(?:(?&V)|\((?&W)(?&E)(?&W)\))(?:(?&O)(?&E))?)#
)#
((?&E))").unwrap();
let string = "(8 - 1 + 3) * 6 - ((3 + 7) * 2)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}