const regex = /# https://regex101.com/r/fP1oQ6/2
(?(DEFINE)#
(?<W>\s*)
(?<V>\d+(?:\.\d+)?(?&W))
(?<S>[-+]?)
(?<O>(?&W)[-+*\/](?&W))
(?<E>(?&S)(?:(?&V)|\((?&W)(?&E)(?&W)\))(?:(?&O)(?&E))?)#
)#
((?&E))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('# https:\/\/regex101.com\/r\/fP1oQ6\/2
(?(DEFINE)#
(?<W>\\s*)
(?<V>\\d+(?:\\.\\d+)?(?&W))
(?<S>[-+]?)
(?<O>(?&W)[-+*\\\/](?&W))
(?<E>(?&S)(?:(?&V)|\\((?&W)(?&E)(?&W)\\))(?:(?&O)(?&E))?)#
)#
((?&E))', 'g')
const str = `(8 - 1 + 3) * 6 - ((3 + 7) * 2)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}