using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"www-(dev|qa)\.";
string input = @"www-dev.someurl.com
www-qa.someurl.com
www.someurl.com";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}