$re = '/www-(dev|qa)\./mi';
$str = 'www-dev.someurl.com
www-qa.someurl.com
www.someurl.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);