re = /www-(dev|qa)\./mi
str = 'www-dev.someurl.com
www-qa.someurl.com
www.someurl.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end