package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)www-(dev|qa)\.`)
var str = `www-dev.someurl.com
www-qa.someurl.com
www.someurl.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}