using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*\d.*\d)(?=.*[A-Z].*[A-Z]).{8,}";
string input = @"foo1Bar2Qux
foo
bar
123
QX12
1fooBAR2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}