re = /(?=.*\d.*\d)(?=.*[A-Z].*[A-Z]).{8,}/m
str = 'foo1Bar2Qux
foo
bar
123
QX12
1fooBAR2'
# Print the match result
str.scan(re) do |match|
    puts match.to_s
end