import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*\\d.*\\d)(?=.*[A-Z].*[A-Z]).{8,}";
final String string = "foo1Bar2Qux\n"
+ "foo\n"
+ "bar\n"
+ "123\n"
+ "QX12\n"
+ "1fooBAR2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}