#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mx)^(?:\+?1?[-.\s]?)\(?(\d{3})\)?([-.\s])?(\d{3})([-.\s])?(\d{4})$"
Local $sString = "+1-555-235-2444" & @CRLF & _
"1-555-235-2444" & @CRLF & _
"1.555.235.2444" & @CRLF & _
"1 555 235 2444" & @CRLF & _
"555-235-2444" & @CRLF & _
"(555) 234-2341" & @CRLF & _
"5552342341" & @CRLF & _
"555 2341234" & @CRLF & _
"555-2341234"
Local $sSubst = "(\1) \3 \5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)