$re = '/^(?:\+?1?[-.\s]?)\(?(\d{3})\)?([-.\s])?(\d{3})([-.\s])?(\d{4})$/mx';
$str = '+1-555-235-2444
1-555-235-2444
1.555.235.2444
1 555 235 2444
555-235-2444
(555) 234-2341
5552342341
555 2341234
555-2341234';
$subst = "(\1) \3 \5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;