using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\+?1?[-.\s]?)\(?(\d{3})\)?([-.\s])?(\d{3})([-.\s])?(\d{4})$";
string substitution = @"(\1) \3 \5";
string input = @"+1-555-235-2444
1-555-235-2444
1.555.235.2444
1 555 235 2444
555-235-2444
(555) 234-2341
5552342341
555 2341234
555-2341234";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}