// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^(?:\+?1?[-.\s]?)\(?(\d{3})\)?([-.\s])?(\d{3})([-.\s])?(\d{4})$").unwrap();
let string = "+1-555-235-2444
1-555-235-2444
1.555.235.2444
1 555 235 2444
555-235-2444
(555) 234-2341
5552342341
555 2341234
555-2341234";
let substitution = "(\\1) \\3 \\5";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}