import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[+-]?(?:[0-9]{1,5})?(?:\\.[0-9]{1,2})?$";
final String string = "Valid\n"
+ "-1\n"
+ "+1\n"
+ "1\n"
+ "+.1\n"
+ "-.1\n"
+ ".1\n"
+ "+11111.11\n"
+ "-11111.11\n"
+ "11111\n\n"
+ "Invalid\n"
+ "+111111.11\n"
+ "-111111.11\n"
+ "+11111.111\n"
+ "-11111.111\n"
+ "11111.111\n"
+ "111111.11\n"
+ "+1.\n"
+ "-1.\n"
+ "1. ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}