import re
regex = re.compile(r"^[+-]?(?:[0-9]{1,5})?(?:\.[0-9]{1,2})?$", flags=re.MULTILINE)
test_str = ("Valid\n"
"-1\n"
"+1\n"
"1\n"
"+.1\n"
"-.1\n"
".1\n"
"+11111.11\n"
"-11111.11\n"
"11111\n\n"
"Invalid\n"
"+111111.11\n"
"-111111.11\n"
"+11111.111\n"
"-11111.111\n"
"11111.111\n"
"111111.11\n"
"+1.\n"
"-1.\n"
"1. ")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")