re = /^[+-]?(?:[0-9]{1,5})?(?:\.[0-9]{1,2})?$/m
str = 'Valid
-1
+1
1
+.1
-.1
.1
+11111.11
-11111.11
11111
Invalid
+111111.11
-111111.11
+11111.111
-11111.111
11111.111
111111.11
+1.
-1.
1. '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end