const regex = /^[+-]?(?:[0-9]{1,5})?(?:\.[0-9]{1,2})?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[+-]?(?:[0-9]{1,5})?(?:\\.[0-9]{1,2})?$', 'gm')
const str = `Valid
-1
+1
1
+.1
-.1
.1
+11111.11
-11111.11
11111
Invalid
+111111.11
-111111.11
+11111.111
-11111.111
11111.111
111111.11
+1.
-1.
1. `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}