import Foundation
let pattern = #"^(?:(?:fix|feat|docs|doc|breaking|revert|chore|perf|test|style|refactor)(?:\([\w\s]+\))?:).*(?:(?:OS[:\-\s]\s*([0-9]+))|((?:ska|SKA)-(?:[0-9]+))).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
chore: Mudanças de configuração ou de ska-7777 código que não entra em produção;
docs(sdsdsds): Mudanças na documentação ska-7777;
style: Alteração apenas no estilo do código, ska-7777 sem mudança de algoritmo;
refactor: Refatoração de determinado ska-7777 bloco de código;
perf: Alterações que impactam o desempenho da aplicação OS 99999;
test: Mudanças na OS:99999 estrutura ou na forma de testar o projeto.
feat: dksdOS: 99999jskdjksdksdskdjkjk
fix: dsdsdsdsd OS: 99999
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)