import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:(\\+?972|\\(\\+?972\\)|\\+?\\(972\\))(?:\\s|\\.|-)?([1-9]\\d?))|(0\\d{1,2}))(?:\\s|\\.|-)?([^0\\D]{1}\\d{2}(?:\\s|\\.|-)?\\d{4})$";
final String string = "Valid:\n"
+ "972 54-333-4444\n"
+ "+972-54-333-4444\n"
+ "02-3334444\n"
+ "02 3334444\n"
+ "023334444\n"
+ "050-333-4444\n"
+ "(+972)54-333-4444\n"
+ "+(972)50 333 4444\n"
+ "0753334444\n"
+ "972543334444\n\n"
+ "Invalid:\n"
+ "02-033-4444\n"
+ "23334444\n"
+ "02-33-4444\n"
+ "654-333-4444\n"
+ "973 54 3334444\n"
+ "972 054 3334444\n"
+ "972 02 333 4444";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}