const regex = /^(?:(?:(\+?972|\(\+?972\)|\+?\(972\))(?:\s|\.|-)?([1-9]\d?))|(0\d{1,2}))(?:\s|\.|-)?([^0\D]{1}\d{2}(?:\s|\.|-)?\d{4})$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:(\\+?972|\\(\\+?972\\)|\\+?\\(972\\))(?:\\s|\\.|-)?([1-9]\\d?))|(0\\d{1,2}))(?:\\s|\\.|-)?([^0\\D]{1}\\d{2}(?:\\s|\\.|-)?\\d{4})$', 'gm')
const str = `Valid:
972 54-333-4444
+972-54-333-4444
02-3334444
02 3334444
023334444
050-333-4444
(+972)54-333-4444
+(972)50 333 4444
0753334444
972543334444
Invalid:
02-033-4444
23334444
02-33-4444
654-333-4444
973 54 3334444
972 054 3334444
972 02 333 4444`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}