import re
regex = re.compile(r"^(?:(?:(\+?972|\(\+?972\)|\+?\(972\))(?:\s|\.|-)?([1-9]\d?))|(0\d{1,2}))(?:\s|\.|-)?([^0\D]{1}\d{2}(?:\s|\.|-)?\d{4})$", flags=re.MULTILINE)
test_str = ("Valid:\n"
"972 54-333-4444\n"
"+972-54-333-4444\n"
"02-3334444\n"
"02 3334444\n"
"023334444\n"
"050-333-4444\n"
"(+972)54-333-4444\n"
"+(972)50 333 4444\n"
"0753334444\n"
"972543334444\n\n"
"Invalid:\n"
"02-033-4444\n"
"23334444\n"
"02-33-4444\n"
"654-333-4444\n"
"973 54 3334444\n"
"972 054 3334444\n"
"972 02 333 4444")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")